Outage - NA4
Incident Report for QLess
Postmortem

We would like to provide additional detail surrounding the downtime which occurred on 3/08/2021

What happened?
At 9:28am PST, the NA4 server environment experienced downtime which resulted in all QLess applications becoming temporarily inaccessible on the server.
Duration: 18 minutes.

Cause
As a result of a regular “cache clear" action, QLess service became unresponsive as routinely running threads were blocked from execution.

Remediation
Upon receiving a monitoring alert notification QLess engineers restarted the service.

Prevention
QLess has initiated a complete refactoring of the affected application. The new service application will be more fault-tolerant, available and self-healing.

Posted Mar 08, 2021 - 10:34 PST

Resolved
QLess services are now operational.
Posted Mar 08, 2021 - 09:46 PST
Investigating
We are currently investigating this issue.
Posted Mar 08, 2021 - 09:29 PST
This incident affected: NA4.