NA1 Partial outage
Incident Report for QLess
Resolved
QLess services are fully operational now.
Posted Apr 12, 2023 - 18:05 PDT
Update
We're currently investigating an issue where scheduled appointments are not being added to queues. We will provide an update on this issue as the investigation proceeds and we bring it to a full resolution.
Posted Apr 12, 2023 - 12:34 PDT
Investigating
We are currently investigating this issue.
Posted Apr 12, 2023 - 12:30 PDT
This incident affected: NA1.