NA6 Outage
Incident Report for QLess
Postmortem

At 12:57am PST, the NA6 server environment experienced downtime which resulted in all QLess applications becoming temporarily inaccessible on the server.
Duration: 6 minutes.

Cause
The root cause of the outage was due to a rare condition that was triggered on one of our backend servers. Customers reaching the site during that period of time could not reach the site, affecting 100% of them.

Remediation
Upon receiving a monitoring alert notification QLess engineers restarted the service.

Prevention
QLess has initiated a complete refactoring of the affected application. The new service application will be more fault-tolerant, available and self-healing.

Posted Apr 29, 2021 - 14:25 PDT

Resolved
QLess services are now operational.
Posted Apr 27, 2021 - 13:03 PDT
Investigating
We are currently investigating this issue.
Posted Apr 27, 2021 - 12:57 PDT
This incident affected: NA6.