SMS Problems
Incident Report for QLess
Postmortem

On March 8 18:00 UTC we experienced the start of a partial SMS outage. The outage was caused in part by a new initiative that has been put in place by the mobile carriers. This new initiative placed a limit to the number of SMS messages that we were allotted to send per day and impacted only (T-Mobile, Sprint, and MetroPCS).  The following days we worked with our provider Twilio to have the limit that was placed on the account increased to ensure that there would have little to no interruption in service to our customers. We were advised finally after a couple of days that the limit had indeed been increased however the changes were not showing correctly on our end due to what we later found out was a bug in the provider's system. Once they were able to resolve the disconnect on their end and update our settings, we started monitoring the traffic to verify that the changes had indeed taken effect. Moving forward and to ensure this does not occur again we will continue to work with our provider to increase the traffic limits as much as possible.

Posted Mar 17, 2022 - 17:28 PDT

Resolved
We have continued to monitor this issue throughout the day and can confirm that it is now resolved.
Posted Mar 17, 2022 - 17:27 PDT
Monitoring
We have been advised that our limits have now been adjusted to a higher amount which will ensure that there is little to no interruption to your day. We will continue to monitor the traffic throughout the day to ensure that we do not foresee any additional information once we have completed the monitoring of the service, we will consider the issue resolved and will provide the postmortem. Thank You again for your patience while we worked to rectify this issue.
Posted Mar 16, 2022 - 03:06 PDT
Investigating
We have been informed that T-Mobile has started limiting the number of outbound messages to consumers (this will also impact Sprint and Metro PCS. We are currently working on increasing that limit with our provider Twilio. Until this happens, you may have intermittent issues with SMS for any T-Mobile, Sprint, and MetroPCS customers. All Verizon and AT&T customers are not impacted. We will continue to provide additional updates as they become available.
Posted Mar 08, 2022 - 15:47 PST
Update
We believe the issue that was impacting SMS for Tmobile users is now resolved. However, we will continue to monitor the issue throughout the day to ensure that there are no additional problems.
Posted Mar 08, 2022 - 11:23 PST
Update
We have isolated the issue with SMS to be with T-Mobile and Sprint and continue to work with our provider to resolve the issue. We will continue to provide updates as they are available.
Posted Mar 08, 2022 - 08:29 PST
Monitoring
We are continuing to monitor the intermittent SMS issues and will provide additional updates as they become available.
Posted Mar 07, 2022 - 18:36 PST
Investigating
We are currently investigating an issue that may be causing intermittent problems preventing customers from sending SMS commands such as status updates or leaving the queue. We will continue to provide updates as they are available as we work with our provider to resolve the problem.
Posted Mar 07, 2022 - 12:11 PST
This incident affected: AU1, CA1, EUR, US, US1, US2, NA1, NA2, NA3, NA4, NA5, NA6, NA7, NA8, NA9, and NA10.